Notice: Undefined variable: position6 in /home/domains2/public_html/jacques-cousteau.com/show.php on line 114

Guide :Grilling : Genesis Silver C Grill

I move mobile homes for a living. I have a weber omni hitch on my toter truck. I have replaced the switches, plugs, and wiring on the controller. The hitch goes in and out, up and down, and left and right. I have had an intermitent problem with the hitch mostly not wanting to go right. Now it is no longer intermitent and won't go right at all. The spool valves are not stuck. The pump is operating at 2600 psi. It is supposed to operate at 2500 psi. Have had the reservoir off and it is clean inside and the filter is clean also. There is a light on the magnet spool valve assembly idicating that there is power reaching each assembly of which there are three. One controls in/out, up/down, and the third left/right. The ownner of the company said we still might have a bad wire between th light and the magnet so we replaced the middle spool valve assembly which controls the right/left directions. We replaced it on the weekend so I couldn't get them on the phone for more troubleshooting ideas. There are no leaks any where so I susspect that there is a check valve that is stuck or some other problem with the cylinder that pushes it to the right. How do I check the left and right cylinders to see if there is a problem? what would I be looking for? And what needs to be done to fix any possible problems with the cylinders?

Posted by sassy becca on Apr 07, 2008

Research, Knowledge and Information :



Notice: Undefined variable: go_page in /home/domains2/public_html/jacques-cousteau.com/show.php on line 182

Notice: Undefined variable: go_page in /home/domains2/public_html/jacques-cousteau.com/show.php on line 213


We did not find results for: i move mobile homes for a living i have a weber omni hitch on my toter truck i have replaced the switches plugs and wiring on the controller the hitch goes in and out up and down and left and right i have had an intermitent problem with the hitch mostly not wanting to go right now it is no longer intermitent and won t go right at all the spool valves are not stuck the pump is operating at 2600 psi it is supposed to operate at 2500 psi have had the reservoir off and it is clean inside and the filter is clean also there is a light on the magnet spool valve assembly idicating that there is power reaching each assembly of which there are three one controls in out up down and the third left right the ownner of the company said we still might have a bad wire between th light and the magnet so we replaced the middle spool valve assembly which controls the right left directions we replaced it on the weekend so i couldn t get them on the phone for more troubleshooting ideas there are no leaks any where so i susspect that there is a check valve that is stuck or some other problem with the cylinder that pushes it to the right how do i check the left and right cylinders to see if there is a problem what would i be looking for and what needs to be done to fix any possible problems with the cylinders.

Notice: Undefined variable: position4 in /home/domains2/public_html/jacques-cousteau.com/show.php on line 230

Loading ...

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Notice: Undefined variable: position5 in /home/domains2/public_html/jacques-cousteau.com/show.php on line 283
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.jacques-cousteau.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0205 seconds